06/20:システム障害_ログイン関連【復旧済み】

更新履歴

  • 6/27 17時00分:復旧を確認しましたため、情報を更新しました。
  • 6/25 19時00分:「現在の状況」と「今後の見通し」を追加しました。
  • 6/24 17時30分:
    • 追加の暫定対応を実施したことで、一部のお客様において一時的にサーバーエラーが発生しました。現在は復旧し、自動復旧までの時間が大幅に短縮されました。
    • 「エラー発生時の対処方法」の案内を更新しました。
  • 6/24 13時50分:一時的な再発が確認されたため、「直近の障害発生時刻」に履歴を追加しました。
  • 6/24 9時50分:一時的な再発が確認されたため、「直近の障害発生時刻」に履歴を追加しました。
  • 6/23 20時20分:記事内容を更新しました。
  • 6/23 15時00分:一時的に再発したため、情報を更新しました。

 

以下の期間において障害が発生しておりましたが、一定期間の経過観察を経て再発がないことを確認できましたため、復旧のご報告をさせていただきます。現在は、通常通りご利用いただける状態となっております。

改めまして、ご利用中のお客様には多大なるご迷惑をおかけしましたこと、深くお詫び申し上げます。今回の障害ではログインができない事象が発生し、ログイン画面上でのご案内ができない状況となったことを踏まえ、PC管理画面やヘルプサイトに限らず、より早期に広くお知らせできるよう、運用体制の改善を進めてまいります。

■障害発生期間

2025年6月20日(金) 15時25分ごろ 〜 2025年6月27日(金) 15時00分ごろ

■ 発生履歴 (発生〜復旧)

  • 2025年6月20日(金)15:25ごろ ~ 16:23ごろまで
  • 2025年6月23日(月)13:30ごろ ~ 13:40ごろまで
  • 2025年6月23日(月)16:41ごろ ~ 16:51ごろまで
  • 2025年6月24日(火)9:27ごろ ~ 9:32ごろまで
  • 2025年6月24日(火)13:30ごろ
  • 2025年6月24日(火)16:02ごろ 〜 16:37ごろまで(追加の暫定対応に伴い、一部のお客様において一時的にサーバーエラーが発生)

■対象アプリケーション

  • PC管理画面
  • アプリ(Fleet Driver/Fleet Station)

■障害内容

  • ログイン画面が表示されない
  • ログインに失敗する
  • ログイン中にログアウトされる

なお、ログイン以外の機能は正常に動作しており、走行データやログイン後に記録された内容については問題なく確認・記録されております。

■ 原因

WEBやアプリからのアクセスをサーバー側で認証する際、必要な情報を定期的に認証基盤から取得していますが、その処理中に認証基盤のアクセス制限(レートリミット)に抵触してしまいました。その際の回避処理に問題があり、利用中のお客様が一斉にログアウト状態となる事象が発生しました。これをきっかけとしたログインの増加により、認証部分に通常のピーク時の数十倍のアクセスが集中し、6/20の事象につながりました。

■ 対応履歴

  • 2025年6月23日(月) :ログインエラーが発生した際に自動回復できるよう、10分間隔で復旧処理を行う設定を導入しました。これにより、エラー発生から10分以内に自動復旧できる体制を整えました。
  • 2025年6月24日(火) :追加の暫定対応を実施したことで、復旧処理の間隔が10分から数秒に短縮され、自動復旧までの時間が大幅に短縮されました。
  • 2025年6月25日(水) :エラーの発生率を引き下げる対応を実施しました。
  • 2025年6月27日(金) :上記の暫定対応を実施後、一定期間の経過観察を行い、同様の事象が再度発生していないことを確認しました。

 

このたびはご迷惑をおかけしましたこと、深くお詫び申し上げます。今後も安定したサービスの提供に努めてまいりますので、変わらぬご支援を賜りますようお願い申し上げます。

 

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています